Disappearing Shortcut Dimensions

One of my favorite features of Dynamics 365 Business Central and Dynamics NAV is the way the chart of accounts is designed. Rather than needing to define an entire account string (as you would when setting up the COA in Dynamics GP), you need only define the natural (main segment) account number, and then define available dimensions. This makes adding business units, departments, and other segments to the chart of accounts very easy.

In recent updates to Business Central, Microsoft has made efforts to expose more of the shortcut dimensions in the G/L Entry tables. Here is a link to the relevant area of the 17.3 release notes: Use shortcut dimensions in G/L entries for financial reporting – Dynamics 365 Release Plan | Microsoft Docs. This is a huge benefit for businesses that use Jet Reports for financial reporting.

If you have default shortcut dimensions set up for customers, vendors, items, jobs, etc. or you are using shortcut dimensions, there is a bug in release 17.3 that may impact your reporting (your tenant would have received an update sometime in late January).

During transaction entry, users assign shortcut dimensions. However, in the preview posting screen, the dimensions appear as blank when you drill into the G/L Entries. The dimensions also do not appear in the GL Entry after the document is posted. They do however appear on the posted document in the sub-ledger (e.g., sales, purchasing, jobs). Here is an example of the issue in action. In my test environment, I have four dimensions set up. My two global dimensions are Division Code and Customer Group. I have two additional shortcut dimensions set up to track departments and EBIDTA add-backs.

In the below transaction, I am using three dimensions: Division, Department, and Addbacks. I am not using a customer group dimension here. I have assigned each of them on the below purchase invoice. The expected behavior of Business Central is that the G/L entry that the posting of this invoice generates would be tagged with these dimensions.

When I click on the preview posting button and then drill into the G/L entries, the dimensions do not appear.

After posting the entry, the same behavior occurs. This issue appears to impact all tenants using Shortcut Dimensions. It appears that the dimension set ID is still written to the G/L Entry table, but the shortcut dimension values do not appear there.

Here is a screenshot of the G/L Entry table after posting:

Here is a screenshot of the G/L Entry table in Jet Reports, where you can also see the issue. No shortcut dimensions assigned:

Notice the dimension Set ID has however been assigned. When you search the dimension set entry table for this dimension set ID you can see that the dimension set entries are still there:

This issue should be addressed in version 17.4, which will be making its way to US tenants soon.